Странное поведение регуля RCTimer 30A

После сбора квадрика, удалось немного полетать. Но вдруг в полете выключился один двигатель. Высота была небольшая, ведь я только учился, и квадрик благополучно упал набок в траву. Где-то непропай подумал я… проверил все соединения (у меня все двигатели и регуляторы спаяны намертво без разъемов). Все было на месте и держалось крепко.
Странно - подумал я… Сделал АРМ двигателей. Один из двигателей начал странно дергаться, остальные три вращались нормально. При добавлении газа больной движок продолжал судорожно дергаться. И вдруг больной завелся и стал вращаться и реагировать на газ нормально, как и его здоровые братья.
ДИЗАРМ-АРМ больной вращается и останавливается одновременно с остальными… Глюк -подумал я и попробовал взлететь. И оно полетело!
Уже дома, после зарядки акка, попробовал снова завести квадрик и опять дерганья больного движка, потом снова начинает вращаться нормально.
Сначала я думал, что виноват движок и поменял его местами с другим. Симптомы сохранились на другом моторе. Т.е виноват регулятор.
Ну держись -подумал я, и поменял прошивку в подозрительном ESC,и … ничего не изменилось. Как дергался так и дергается… Если подключить рег-мотор напрямую в канал газа приемника, то никаких дерганий я не заметил (хотя может быть просто повезло, потому что с вероятностью 50/50 оно иногда заводится нормально). Подключаешь в контроллер - дергается, потом заводится. Все видно на видео на 25-35 секундах. Может быть кто сталкивался с таким поведением?

Сетап:
Моторы - RCTimer HP2812
Регуляторы - RCTimer 30А simonK fw
Контроллер - AIOP v2 RCTimer
Прошивка MultiWii 2.2

  • 3274
Comments
vavilon09
  1. сделай калибровку регуля.
  2. Скорее всего вылетели часть ключей на одно плечо.
    Варианты лечения:
    Поменять регуль,
    Найти сгоревшие ключи и поменять
gonza34

Калибровку делал и через канал газа, и через мультивий. Результат один. Мне кажется, что если бы сгорели ключи, то он бы вообще не работал. А так работает же, но запускается через какое то время. Больше похоже на непропай внутри регулятора.

Dimmitri

Мдя, нечто подобное у меня тоже наблюдается, регуляторы тоже от тудава:( dev.rcopen.com/forum/f123/topic260776/2210

Anatoly84

У меня на мультивии SE тоже такое же с регуляторами Plush 40A причем и с прошитым и не прошитым. При прямом подключении к приемнику работает а при подсоединении к мультивии один то не стартует то стартует. Причем поменял один двиг с регулем стал другой хондрить.

SovGVD

> Мне кажется, что если бы сгорели ключи, то он бы вообще не работал.
в одном канале из 3х непропай или странный коротышь, вот он и дергается, лучше заменить регуль

gonza34
Anatoly84;bt104486

У меня на мультивии SE тоже такое же с регуляторами Plush 40A причем и с прошитым и не прошитым. При прямом подключении к приемнику работает а при подсоединении к мультивии один то не стартует то стартует.

Я уже и на контроллер AIOP грешил, думал вдруг что не так с мозгов идет. Поменял подключение больного и нормального регулятора на плате AIOP. Пофиг-больной дергается.
А вы мегапирата не пробовали? Может быть на нем не будет таких проблем?

vavilon09

В регуляторе на плече стоит от 5-6 ключей скорее всего вылетели 2 ключа на одно плечо.

AlcoNaft43

или обрыв одной из фаз мотора внутри изоляции

zvuk_Irkutsk

Есть такая же проблема, у товарища моего, регуль рцтаймер 20А, мозг ардукоптер.
При первом взлете - как будто срыв синхронизации, коптер валится на больной регуль, но если высота более трех метров, то упасть аппарат не успевает, т.к. регуль опять заводится и полет продолжается.
Нашлось странное решение на время, пока не приедет запасной - после “прогрева”, минуты через три, все становится нормально, похоже на непропай или действительно бракованные ключи.

Anatoly84
gonza34;bt104511

Я уже и на контроллер AIOP грешил, думал вдруг что не так с мозгов идет. Поменял подключение больного и нормального регулятора на плате AIOP. Пофиг-больной дергается.
А вы мегапирата не пробовали? Может быть на нем не будет таких проблем?

Я уже не знаю на что грешить. По порядку что к чему.

  1. Собрал коптер на регулях Turnigy Plush 40A все работало с КК контроллером.
  2. Перепрошил регули на BLHeli все работало с тем же контролером. Проблема была одна - настроить устойчивое поведение коптера не смог но для КК очень не плохо летало. Было пару крашей но все проверялось и работало.
  3. Пришел MultiWiiSE с рстаймера я его поставил на коптер вместо КК. Тут и начались проблемы. Настроил прошивку 2.2 в гуи все замечательно, передатчик видит отрабатывает моторами как надо. Подключаю регули, включаю коптер - никакой стабильности. Колбасит по страшному. Резкие прыжки вверх. Ну думаю пиды нужно крутить.
  4. Пока крутил пиды отрубился один двиг. После подключения питания и арма дергается и иногда попискивает как будто питание теряет.
  5. Меняю регуль вместе с двигом на другую не прошитую связку так как думал что силовой провод перебит или фаза. Снятую пару регуль двиг включаю отдельно в приемник - все работает. Включаю коптер. Те же симптомы но с другой парой двиг-регуль. Новый регуль пищит не видя сигнала хотя диапазон откалиброван. Итого на квадре две СУ не работают.
  6. Сегодня меняю MultiWii на Ardupilot2.5 (диапазоны не калибрую на регулях специально дабы было минимум изменений). Итог. Новый регуль стартует. А вторая пара так и хондрит.

Как руки дойдут собираюсь по новой перепрошить все регули и перекалибровать их заново. Дело как видно не в MultiWii хотя к ней тоже есть вопросы.

gonza34

Заказал еще пару регулей с рц-таймера, посмотрим как они себя поведут. Попробовал залить в AIOP мегапирата, так вообще на нем не смог запустить моторы. Плата в MissionPlanere видится, все наклоны отрабатывает, аксель калибруется. Но при попытке калибровки регулей (газ в максимум, подключаем питание к коптеру) от регулей никакой реакции. Они просто инициализируются и в режим калибровки не входят, хотя на плате начинают последовательно мигать все светодиоды. Если сделать арм, то загорается красный светодиод на контроллере (после загрузки AIOP в режиме ДИЗАРМ он просто моргает), но двигатели на газ никак не реагируют. В общем загадка…

Anatoly84

На оригинальном Ардупилоте надо включить питание с газом в максимум дождаться мигания потом выключить и включить снова. Если мне не изменяет память)

gonza34

Вроде бы я так и делал - подключал 2 раза питание, с газом в максимум… Попробую еще раз.
Больной регулятор совсем умирает. Вчера смотрел осциллографом, какой сигнал идет с мосфетов. Так после судорог мотора в течении полминуты, сигнал на моторы вообще пропадает и он перестает дергаться. Если мотор все таки запустился, но его остановить рукой на холостых оборотах, он начинает дергаться и через секунд 30 останавливается.
С мосфетов прет какая-то муть по всем трем плечам, в то время когда мотор дергается. Я то думал, что только одно плечо будет давать кривой сигнал из-за нерабочих ключей.
Кстати все ключи прозвонил, все они одинаковые. Как тут писали, пробитых я не нашел.
Подозреваю, что дело не в ключах, а в самой плате контроллера ESC. Что-то там либо не запускается, либо не тот сигнал выдает на мосфеты.

Anatoly84

Я тоже все перепрошил но один регуль так и хондрит. Хотя работает лучше. Может покопаться в настройках прошивки BLHeli? Может есть у кого нибуть работающий конфиг и опыт настройки?

DmS

2 регуля RCTimer 30A OPTO также повели себя из последней партии, сперва подумал что срыв синхры и т.д., а потом поменял их и всё ОК,
с пред.регулями не OPTO такого ни разу не было и с прошитыми и не прошитыми - были проблемы с пайкой у одного например.
так что заказывать подобную электронику нужно всегда в 1,5 раза больше чем необходимо 😃

raefa

Регуль RCTimer 30A SimonK, мотор 2830-11 1000kv.
После нескольких полетов на гексе (новые 6 регуляторов и моторов) один мотор начал при старте дергаться. Либо крутить дальше, либо стартануть заново раз 5-10 (типа прогрев) и дальше крутился нормально. День полежит дома, запускаю и опять такая беда, на третий день такое не повторилось. Дальше начал исследование неспешно. Попытался вынести на балкон или холодильник (+5°), подождал минут 20, попробовал завести - заводится, подождал в тепле - заводится. Подождал сутки в тепле - опять рандом, но раза с 5-10 также нормально стартует. ну явно очень похоже на регулятор, но начал сначала осмотр мотора. Качество изготовления по сравнению с давностью год - значительно хуже. Коррозия на тонких проводках съела местами лак и жила меди стала тоньше. Раз 5 погнуть и ломается. Намотка стала кошмарной (год назад было виток к витку). Пропаял явные косяки, собрал. Попробовал завести - результата нет. Опять рандомный запуск, но после “прогрева” работает нормально.

Сегодня пропаял регуль. Все полностью. Кажется был непропай у 2х резисторных сборок (33кОм) на некоторых контактах. При касании пальцем мотор начинал также себя вести. Промыл спиртом, попробовал опять завести. Пока все гуд и надеюсь завтра и дальше такое не повторится. Сегодня отлетал 2 акка без приключений.

DmS

Регуль RCTimer 30A SimonK OPTO, мотор sunsky 850kv + prop 12x3.8.
из 8-ми купленных 2 также запускались - в полете отрубались (срыв синхронизации или ещё что), остальные 6 штук работают на ура без проблем на гексе

Подскажите как вернуть к жизни регуль XP-35A-SW (switch) .Нормально работал .Отключил питание передатчика при включенной модели (газ на min) —Завращался моторчик на 1\3 оборотов от max. затем взял и отключил питание регуля. После этого молчит не пищит .Ставил стик на max включал питание перекидывал стик --и тишина. не сжег же я его?